Custom Field Text Not Showing Up In Report


#1

Hi, Nik

For this decision tree …

https://west-island-digital.leadshook.io/survey/NUq3tVf62qxFSrrr60HgBIpOtTc4dR7angHjaszR?preview=true

… the following fields are not showing up properly in the report

{DSI_E_Hand} and {DSI_T_Hand}

I have tried everything I can think of to fix it and it was working and now it’s not.

Not sure why. Those fields are no different to the other fields that are working.

Cheers, Trudy


#2

@Trudy

I had a quick look. Field setup is correct.

Where are you assigning the value to these fields? Which node/question(s)?

Thanks,
Nik


#3

Hi, Nik

In the question entitled “Handsfree Phone?” down near the bottom of the decision tree.

Cheers, Trudy


#4

@Trudy,

Worked for me. I think you have needed to clear your cache.

Nik


#5

I tried it in an incognito window and it didn’t work, but will try clearing my chache.

Cheers, Trudy


#6

No didn’t work. Also using another browser doesn’t work either.

Cheers, Trudy


#7

Hi @Trudy

I tried it again… (in firefox)
https://west-island-digital.leadshook.io/survey/NUq3tVf62qxFSrrr60HgBIpOtTc4dR7angHjaszR?preview=true

Nik


#8

Leave it with me. I’ll ask one of the guys to check as well.

Can you please confirm you’re using the same link as above.

Nik


#9

Hi, Nik

Yes, I used the link you put in above and I still get a null result.

Cheers, Trudy


#10

@Trudy,

Can you please confirm if you’re getting this even if DT is activated?

Nik


#11

Yes, still a problem after activation even though I cleared my cache, tried it in an incognito window and on a completely different computer.

But … it now works in Firefox.

The gremlins are playing with us … :slight_smile:

Cheers, Trudy


#12

@Trudy

Not a bug!

Why?

If you take a different route, i.e. phone not used then these fields have no value.

So please create a new results page without this row and use a decision node to show the correct one.

User error I’m afraid. :slight_smile:

Nik


#13

Or assign a blank value… but the table might look a bit weird with a blank row.


#14

Thanks, Nik

Yes, I just tried it using a different answer in Firefox and got the error again so it has to be a problem with the field and you’re right, it’s a logic problem. I got it now.

On a different note … I have never been able to get the blank value concept to work … it always just shows the name of the custom field.

Thanks for persevering with this one. It had me stumped.

Have learned another lesson about the process to use in trouble shooting.

Cheers, Trudy


#15

For most fields, it’s as simple as adding in a default value.

For the image field, we don’t have a default value/image. So please assign a ‘blank’ image for the field on the alternate path.

Nik