Decision Tree Isn't Flowing Through Its Sequence Properly


#1

Hi, Nik

Please see https://west-island-digital.leadshook.io/survey/CgjMyisJxX7bSZxY0bSxF893GjS44FMmKW9ysCAt?preview=true

For some reason, when I try to test it, it gets stuck on the node entitled Factor #1 - Dropdown. I’ve tried using other forms of nodes, but nothing seems to make a difference.

I’m pretty sure it’s probably something incredibly minute that’s causing it, but I haven’t been able to figure it out.

If you could have a look, I would be grateful.

Cheers, Trudy


#2

Hi Trudy, I saw an error come through a few mins ago.

“Duplicates in a repeater are not allowed. Use ‘track by’ expression to specify unique keys. Repeater: error in contentErrors, Duplicate key: string:“d_factorx” is an invalid field name., Duplicate value: “d_factorx” is an invalid field name.”

Can you please check and see if custom field has been created twice or has some other issue with it?
“d_factorx”

Please add a 1 at the end “d_factorx1” and see if that resolves the issue.

Nik


#3

Hi Trudy, I could not locate any usage of this field… d_factorx

My guess is you had created a field and wanted to replace x with 1, 2, etc.

I was able to get to final results page

Nik


#4

Hi, Nik

I did have a d_factorx, but am pretty sure I deleted it. I can’t find it in either of the two decision trees that originally contained it.

And I still cannot get my results page to show up. Not on Chrome and not on Safari. I don’t know what the deal is.

I’ve cleared my cache and cookies on Chrome and just get back an error message saying I don’t have an account with LeadsHook. And I did the same with Safari, to no avail … no results page.

Any ideas?

Cheers, Trudy


#5

Hi Trudy,

I am sorry to hear that the problem persists.

We are unable to reproduce this issue, the final results page is showing.

Could you please share with us the exact answers that you input, we will check again on our end.

If you can record a screencast of the entire process and share the video with us, that would be great.

Thanks!


#6

Thanks, Chun

I went back through each component of the node causing the problem and finally found which bit was causing the issue. Not sure why it was causing it, but at least it’s fixed.

Cheers, Trudy


#7

@Trudy

What was the issue? Is this a bug?

Please let us know so we can get it fixed.

Thanks,
Nik


#8

Hi, Nik

There were two parts to it.

The first one was user error. In the node that was causing the problem I had incorrectly formatted one of the values in one of the dropdown box responses. As soon as I fixed that it worked fine.

The second part is still a bit of a mystery to me. I don’t understand why that one issue made it impossible for me to see the results page, but you could.

So probably nothing to fix at this stage. Just another thing in the long list of things I’ve learned to do when trying to debug my decision trees :wink:

Cheers, Trudy