Problems with transferring leads to AWeber


Hi, Nik

I’m having problems getting LeadsHook to transfer leads over to AWeber.

Whilst problem solving, I have discovered and fixed a number of issues. I’ve mapped (and re-mapped the fields). I’ve removed and reinserted the ESP node within the LH canvas.

However, now, whenever I “retry” to send the leads across I get an error message that says “undefined”. Plus I can’t get LH to download the list of leads.

Here’s the link to the canvas –

I’m sure it’s something silly I have or haven’t done, but I’ve exhausted my list of ways to figure it out (including checking out other things people have tried … )

Cheers, Trudy


Hi @Trudy,

I deleted and added the node again and it worked.



Thanks, Nik

Maybe there are two separate issues going on here? You’ve fixed one, but the other one is still a problem.

Your email transferred, which is good, but the ones that were captured prior to that have not and I can’t get them to transfer.

Clicking on “retry” just creates that “undefined” error message I mentioned.

Cheers, Trudy


Hi @Trudy,

I think that’s because the ESP was incorrectly setup or something else had gone wrong.

The easiest thing to do is to manually transfer them. Export and import.



Hi, Nik

Yes, I’ve done that. But it wouldn’t export yesterday either …

Worked today though, so hopefully all good.

Cheers, Trudy


Yes, there was an issue with exports. Got fixed today.